第一股票公式网,股票公式,股票,公式下载,指标公式 设为首页加入收藏
你的位置:第一股票公式网飞狐公式绝无仅有的macd买入点公式主图版下载 飞狐仅有的绝无指标 源码

绝无仅有的macd买入点公式主图版下载 飞狐仅有的绝无指标 源码

  • 公式类型:飞狐公式
  • 推荐星级:
  • 公式安全:已通过5款杀毒软件查杀,请放心下载!
  • 更新时间:2019-01-11 07:23:36
  • 相关标签:MACD
  • 运行环境: WinXP/Win7/Win8/Win10/Win All
  • 公式语言:用简体中文编写

绝无仅有的macd买入点公式主图版下载 飞狐仅有的绝无指标 源码详细说明

第一股票公式网(www.chnmoney.com)告诉您:当前正要下载:绝无仅有的macd买入点公式主图版下载 飞狐仅有的绝无指标 源码

input:n(3),nn(18),pp(34),低点参数(10),高点参数(8);
//VERTLINE(VOL=HHV(VOL,nn)),lineDOT,color000099;
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(涨停,OPEN,CLOSE,7,0),COLORRED;
STICKLINE(涨停,h,h,80,0),COLORRED,shift4;
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,7,0),COLORGREEN;
lnn:=BARSLAST((VOL=HHV(VOL,nn)));
K:=lnn=0;
K1:=SUMBARS(K,1);

ydh:=REF(h,K1-1);
ydd:=REF(LOW,K1-1);
DRAWTEXT((ISLASTBAR = 1),ydh,('高:' + NUMTOSTR(ydh,2))),ALIGN1,shift1,colorcyan;
DRAWTEXT((ISLASTBAR = 1),ydd,('低:' + NUMTOSTR(ydd,2))),ALIGN1,shift1,colorffffff;

STICKLINE(K1<=30,REF(h,K1-1)*1,REF(h,K1-1),pp,0),COLORcyan,shift3;
STICKLINE(K1<=30,REF(LOW,K1-1)*1,REF(LOW,K1-1),pp,0),COLORgreen,shift3;
STICKLINE(K1<=1,REF(OPEN,K1-1)*1,REF(CLOSE,K1-1),3,0),COLORyellow;
STICKLINE(K1<=1,REF(HIGH,K1-1)*1,REF(LOW,K1-1),1,0),COLORyellow;
平顶:=h=ref(h,1) or (h=ref(h,2) and h>ref(h,1));
顶:partline(平顶,h),coloryellow,linethick2;
平底:=l=ref(l,1) or (l=ref(l,2) and l<ref(l,1));
底:partline(平底,l),coloryellow,linethick2;

STICKLINE(ISLASTBAR,CLOSE*1.1,CLOSE*1.1,45,1),colorred,shift3;
DRAWNUMBER(ISLASTBAR,CLOSE*1.1,CLOSE*1.1,2),coloryellow,shift1;
DRAWTEXT(ISLASTBAR,CLOSE*1.08,'涨停'),COLORGREEN,shift1;

DRAWTEXTEX(CLOSE,1,30,20,'
\n ╔══╗
\n ║ ║
\n ║ ║
\n ╚══╝'),LINETHICK2,Coloryellow;
w:=V>=2*REF(V,1);
DRAWTEXTEX(CLOSE,1,30,20,'
\n ╔══╗
\n ║ ║
\n ║ ║
\n ╚══╝'),LINETHICK2,Colorred;
市值:=CLOSE*CAPITAL*VOLUNIT/100000000;
股本:=FINANCE(1)/10000;
流通:=FINANCE(7)/10000;
股东总数:=FINANCE(50);
主营业务增长率:=FINANCE(53);
税后利润增长率:=FINANCE(54);
净利润增长率:=FINANCE(55);
人均持股:=(FINANCE( 7)/FINANCE(50))*10000;
DRAWTEXT(w,l*0.99,'倍量'),coloryellow;
市盈率:=DYNAINFO(39);
市净率:=CLOSE/FINANCE(34);
F:=COST(5 );J:=COST(95 );
莸利比例:=WINNER(CLOSE )*100;
日换手率:=VOL/CAPITAL*100;

穿透力:(winner(C)-winner(ref(C,1)))/v*capital,linethick0;
DRAWTEXTEX(CLOSE,1,200,60,'穿透力:'),LINETHICK2,Coloryellow;
DRAWTEXTEX(CLOSE,1,300,60,NUMTOSTR(穿透力,2)+'%'),Coloryellow;
DRAWTEXTEX(CLOSE,1,650,60,'莸利比例:'),LINETHICK2,Coloryellow;
DRAWTEXTEX(CLOSE,1,750,60,NUMTOSTR(莸利比例,2)+'%'),Coloryellow;
DRAWTEXTEX(CLOSE,1,400,60,'日换手率:'),LINETHICK2,ColorAFFF00;
DRAWTEXTEX(CLOSE,1,500,60,NUMTOSTR(日换手率,2)+'%'),ColorAFFF00;
ma5:MA(CLOSE,5),colorffffff;
ma10:MA(CLOSE,10)coloryellow;
ma18:MA(CLOSE,18),colorred,LINETHICK2;
ma34:MA(CLOSE,34),colorgreen;
ma60:MA(CLOSE,60),colorblue;
DRAWTEXT((ISLASTBAR = 1),ma18,('ma18:' + NUMTOSTR(ma18,2))),ALIGN1,shift1,colorffffff;
//DRAWTEXT(barstatus=2,ma18,'. ma18 '),linethick2,ALIGN1,colorffffff,shift0;

半分位:=REF((HIGH+LOW)/2,1),COLORYELLOW;
STICKLINE(半分位,半分位,半分位,4,1),COLORyellow,LINETHICK1;

input:N(3);
J1:=ISLASTBAR;
J2:=REF(HIGH,N)=HHV(HIGH,2*N+1);
J3:=FILTER(J2,N);
J4:=BACKSET(J3,N+1);
J5:=FILTER(J4,N);
J6:=J5 OR J1;
J7:=REF(LOW,N)=LLV(LOW,2*N+1);
J8:=FILTER(J7,N);
J9:=BACKSET(J8,N+1);
JA:=FILTER(J9,N);
JB:=JA AND NOT(J5);
JC:=BACKSET(J6,REF(BARSLAST(JB),1)+1);
JD:=JC>REF(JC,1);
JE:=BACKSET(JD,2);
JF:=JE>REF(JE,1);
J10:=BACKSET(JF AND COUNT(J6,REF(BARSLAST(JB),1)+2)=0,REF(BARSLAST(JB),1)+2);
J11:=J10>REF(J10,1);
J12:=BACKSET(J11 AND COUNT(J6,REF(BARSLAST(JB),1)+2)=0,REF(BARSLAST(JB),1)+2);
J13:=J12>REF(J12,1);
J14:=IF(J6,COUNT(JB,REF(BARSLAST(J6),1)+1),0);
J15:=IF(J14=1 AND J6,BARSLAST(JF),0);
J16:=IF(J6 AND REF(LOW,BARSLAST(JF))>=REF(LOW,BARSLAST(J11)),BARSLAST(J11),BARSLAST(JF));
J17:=IF(J14=2 AND J6,J16,0);
J18:=IF(J14>=3 AND J6,IF(J6 AND REF(LOW,J16)>=REF(LOW,BARSLAST(J13)),BARSLAST(J13),J16),0);
J19:=J15+J17+J18;
J1A:=BACKSET(J6,J19);
J1B:=J1A>REF(J1A,1);
J1C:=BACKSET(J1B,2);
J1D:=J1C>REF(J1C,1);
J1E:=J1D OR J1;
J1F:=BACKSET(J1E,REF(BARSLAST(J6),1)+1);
J20:=J1F>REF(J1F,1);
J21:=BACKSET(J20,2);
J22:=J21>REF(J21,1);
J23:=BACKSET(J22 AND COUNT(J1E,REF(BARSLAST(J6),1)+2)=0,REF(BARSLAST(J6),1)+2);
J24:=J23>REF(J23,1);
J25:=BACKSET(J24 AND COUNT(J1E,REF(BARSLAST(J6),1)+2)=0,REF(BARSLAST(J6),1)+2);
J26:=J25>REF(J25,1);
J27:=IF(J1E,COUNT(J5,REF(BARSLAST(J1E),1)+1),0);
J28:=IF(J27=1 AND J1E,BARSLAST(J22),0);
J29:=IF(J1E AND REF(HIGH,BARSLAST(J22))<=REF(HIGH,BARSLAST(J24)),BARSLAST(J24),BARSLAST(J22));
J2A:=IF(J27=2 AND J1E,J29,0);
J2B:=IF(J27>=3 AND J1E,IF(J1E AND REF(HIGH,J29)<=REF(HIGH,BARSLAST(J26)),BARSLAST(J26),J29),0);
J2C:=J28+J2A+J2B;
J2D:=BACKSET(J1E,J2C);
J2E:=J2D>REF(J2D,1);
J2F:=BACKSET(J2E,2);
J30:=J2F>REF(J2F,1);
J37:=BACKSET(J1,BARSLAST(J1D)+1);
J38:=J37>REF(J37,1);
J39:=BACKSET(J38,REF(BARSLAST(J1D),1)+2);
J3A:=J39>REF(J39,1);
J3B:=BACKSET(J1,BARSLAST(J30)+1);
J3C:=J3B>REF(J3B,1);
J3D:=BACKSET(J3C,REF(BARSLAST(J30),1)+2);
J3E:=J3D>REF(J3D,1),Coloryellow,POINTDOT;
DRAWLINE(J3A,LOW,J38,LOW,1),Coloryellow,POINTDOT;
DRAWLINE(J3E,HIGH,J3C,HIGH,1),Coloryellow,POINTDOT;
前一低: REF(LOW,BARSLAST(J38)),Colorcyan,POINTDOT,Linethick3;
前二低: REF(LOW,BARSLAST(J3A)),Colormagenta,POINTDOT,Linethick2;
前一高: REF(HIGH,BARSLAST(J3C)),Colorcyan,POINTDOT,Linethick3;
前二高: REF(HIGH,BARSLAST(J3E)),Colormagenta,POINTDOT,Linethick2;
////////////////////////////////////////////////////////////////////跳空
if datacount<3 then exit;
HH:=H;
LL:=L;
pL:=ll[datacount]; pH:=0;
tk:=if(l>ref(h,1),1,if(h<ref(l,1),-1,0));
for i=datacount-1 down to 2 do begin
if ll<pL then pL:=ll;
if HH>pH then pH:=hh;
if tk=1 and pL<=hh[i-1] then tk:=0;
if tk=-1 and pH>=ll[i-1] then tk:=0;
end;

STICKLINE(tk=1,l,ref(h,1),100,0),COLORGRAY,ALIGN1;
STICKLINE(tk=-1,h,ref(l,1),100,0),COLORGRAY;


可惜飞狐软件不能通过测试,请求改正


绝无仅有的主图(macd买入点)

  >>>请使用本站搜索功能将找到更多相关绝无仅有的macd买入点公式主图版下载 飞狐仅有的绝无指标 源码

下载地址

点这开始下载

精品股票公式

网友评论温馨提示:任何网友发表的言论必须符合国家法律,否则予以删除!

   评论摘要(共有好评 136 条) 请登陆或注册后再发表评论!

     

      验证码:

下载注意

  • 第一股票公式网发布的股票公式主要来源于各大股票论坛,在此谢谢各位老师无私分享原创公式。
  • 引入公式如发现公式名称栏空白,可能是公式使用期限已过。请尝试调整电脑时间到1997年,看能否如正常显示。
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果您发现下载链接错误,请联系管理员报告错误。
  • 第一股票公式网欢迎各位股友帮忙宣传转发本站资源,有您的支持,我们会做得更好!

猜你喜欢

网友爱看

学了又学