第一股票公式网,股票公式,股票,公式下载,指标公式 设为首页加入收藏
你的位置:第一股票公式网飞狐公式自用的组合MA公式下载 飞狐组合指标 源码

自用的组合MA公式下载 飞狐组合指标 源码

  • 公式类型:飞狐公式
  • 推荐星级:
  • 公式安全:已通过5款杀毒软件查杀,请放心下载!
  • 更新时间:2019-01-11 07:23:49
  • 相关标签:组合
  • 运行环境: WinXP/Win7/Win8/Win10/Win All
  • 公式语言:用简体中文编写

自用的组合MA公式下载 飞狐组合指标 源码详细说明

第一股票公式网(www.chnmoney.com)告诉您:当前正要下载:自用的组合MA公式下载 飞狐组合指标 源码

wx:=MA(c,0);
M1:MA(CLOSE,P1);
M2:MA(CLOSE,P2)*if(n<2,wx,1);
M3:MA(CLOSE,P3)*if(n<3,wx,1);
M4:MA(CLOSE,P4)*if(n<4,wx,1);
M5:MA(CLOSE,P5)*if(n<5,wx,1);
M6:MA(CLOSE,P6)*if(n<6,wx,1);
M7:MA(CLOSE,P7)*if(n<7,wx,1);
M8:MA(CLOSE,P8)*if(n<8,wx,1);

急速超跌:=(C-MA(C,34))/MA(C,34)*100<-14;{34日乖离率}

筹码平衡线:REFX(REF(HHV(H,20),1),DATE),COLORRED;
A:=BARSLAST((VOL=HHV(VOL,21)));
A1:=A=0;
B:=SUMBARS(A1,1);
STICKLINE(B<=1,REF(OPEN,B-1)*1,REF(CLOSE,B-1),1,0),COLORyellow;
STICKLINE(B<=1,REF(HIGH,B-1)*1,REF(LOW,B-1),0.5,0),COLORyellow;
异动:=B<=1 AND REF(HIGH,B-1)*1 AND REF(LOW,B-1);
PARTLINE(BARSLAST(异动),REF(HIGH,BARSLAST(异动))),COLORCYAN,linethick1;
PARTLINE(BARSLAST(异动),REF(LOW,BARSLAST(异动))),COLORGREEN,linethick1;

fh:=high;
fl:=low;
sell:=0*fh;
buy:=sell;
signal:=sell;
boxh:sell,linethick0;
boxl:sell,linethick0;
variable:hc=0,lc=0,bt=fh[1],bb=fh[1];
for i=1 to datacount do begin
if hc>1 then begin
if lc>2 and bt<=fh then begin
buy:=1;
for j=i-1 downto i-hc do begin
boxh[j]:=fh[i-hc];
boxl[j]:=fl[i-lc];
end;
hc:=0;lc:=0;
end;
if bt>fh then begin
if lc>2 then begin
if bb>=fl then begin
sell:=1;
for j=i-1 downto i-hc do begin
boxh[j]:=fh[i-hc];
boxl[j]:=fl[i-lc];
end;
hc:=-1;lc:=0;
end else begin
boxh:=fh[i-hc];
boxl:=fl[i-lc];
end;
end;
hc:=hc+1;
if lc>1 then begin
if bb<fl then begin
lc:=lc+1;
if lc=3 then begin
signal[i-hc+1]:=1;
for j=i downto i-hc+1 do begin
boxh[j]:=fh[i-hc+1];
boxl[j]:=fl[i-lc+1];
end;
end;
end else lc:=0;
end else
if lc=1 then begin
if bb<fl then begin
lc:=lc+1;
end else lc:=0;
end;
if lc=0 and hc>1 then begin
bb:=fl;
lc:=lc+1;
end;
end else begin hc:=0; lc:=0; end;
end else
if hc=1 then begin
if bt>fh then
hc:=hc+1
else begin hc:=0;lc:=0; end;
end;
if hc=0 then begin
bt:=fh;
hc:=hc+1;
end;
end;
partline(boxh and boxh=ref(boxh,1),boxh),linedot,coloryellow;
partline(boxl and boxl=ref(boxl,1),boxl),linedot,coloryellow;
stickline((signal||refx(buy||sell,1))&&boxh,boxh,boxl,0.1,0),linedot,coloryellow;
drawicon(buy,low*0.98,4);
drawicon(sell,high*1.02,5);
DRAWNUMBER(refx(buy||sell,1)&&boxh,boxh,100*(boxh-boxl)/boxl,2) colorgreen;
DRAWNUMBER(refx(buy||sell,1)&&boxh,boxl,boxh-boxl ,2) colorwhite;
A1:=boxh and boxh=ref(boxh,1);
A2:=REFX(REF(A1=0,1) AND A1=1,1);
A3:=REFX(REF(A1=1,1) AND A1=0,1);
DRAWLINE(A2,boxl,A3,boxh,0),colorff9900;
DRAWLINE(A2,boxh,A3,boxl,0),colorgreen;
partline(boxh and boxh=ref(boxh,1),(boxh-boxl)/2+boxl),colorff9900;
stickline((signal||refx(buy||sell,1))&&boxh,boxh,boxl,0.1,0),linedot,coloryellow;

ZZ:=BACKSET(refx(buy||sell,1),BARSLAST(signal)/2);ZX:=REFX(REF(ZZ=0,1) AND ZZ=1,1);
DRAWLINE(signal,boxh,zx,boxl,0),linedot,colorgreen;
DRAWLINE(signal,boxh,refx(buy||sell,1),(boxh-boxl)/2+boxl,0),linedot,colorgreen;
DRAWLINE(signal,boxl,zx,boxh,0),linedot,colorff9900;
DRAWLINE(signal,boxl,refx(buy||sell,1),(boxh-boxl)/2+boxl,0),linedot,colorff9900;
DRAWLINE(signal,boxh,ISLASTBAR AND boxh>boxl,boxl,0),colorgreen;
DRAWLINE(signal,boxh,ISLASTBAR AND boxh>boxl,(boxh-boxl)/2+boxl,0),linedot,colorgreen;
DRAWLINE(signal,boxl,ISLASTBAR AND boxh>boxl,boxh,0),colorff9900;
DRAWLINE(signal,boxl,ISLASTBAR AND boxh>boxl,(boxh-boxl)/2+boxl,0),linedot,colorff9900;
ZA:=BACKSET(ISLASTBAR AND boxh>boxl,BARSLAST(signal)/2);ZB:=REFX(REF(ZA=0,1) AND ZA=1,1);
DRAWLINE(signal,boxh,zb,boxl,0),linedot,colorgreen;
DRAWLINE(signal,boxl,zB,boxh,0),linedot,colorff9900;

VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:DRAWICON(买1>0 OR 买2>0,LOW*0.99,14),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'买入'),COLORRED;
S:DRAWICON(卖1>0,HIGH*1.01,14),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖1>0,HIGH*1.02,'卖出'),COLORGREEN;
{股灵吧决策}
VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
F:DRAWICON(CROSS(VAR200,MA(VAR300,5)),LOW * 0.98,14),CROSSDOT,LINETHICK3,COLOREE00EE;
年:MA(CLOSE,22),LINETHICK2,COLORWHITE;

当前月:=FRACPART(ROUND(当前日期/100)/100)*100;
月:=MONTH;日:=DAY;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='1',c,NUMTOSTR(当前月,0)+'月时间之窗:5(小寒)、6、15、20(大寒)、21、*25\n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='2',c,NUMTOSTR(当前月,0)+'月时间之窗:4(立春)、6、15、18(雨水)21\n \n \n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='3',c,NUMTOSTR(当前月,0)+'月时间之窗:5(惊蛰)、6、15、*20(春分)、21\n \n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='4',c,NUMTOSTR(当前月,0)+'月时间之窗:4(清明)、6、15、20(谷雨)21\n \n \n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='5',c,NUMTOSTR(当前月,0)+'月时间之窗:5(立夏)、6、*12、15、21(小满)\n \n \n \n \n'),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='6',c,NUMTOSTR(当前月,0)+'月时间之窗:5(芒种)、6、*14、21(夏至)\n \n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='7',c,NUMTOSTR(当前月,0)+'月时间之窗:7(小暑)、8、15、*19、23(大暑)\n \n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='8',c,NUMTOSTR(当前月,0)+'月时间之窗:*6、7(立秋)、8、18、23(处暑)\n \n \n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='9',c,NUMTOSTR(当前月,0)+'月时间之窗:7(白露)、8、15、*18、23(秋分)\n \n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='10',c,NUMTOSTR(当前月,0)+'月时间之窗:8(寒露)、15、23(霜降)、*31\n \n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='11',c,NUMTOSTR(当前月,0)+'月时间之窗:7(立冬)、8、15、22(小雪)23、*28\n \n \n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(当前月,0)='12',c,NUMTOSTR(当前月,0)+'月时间之窗:7(大雪)、8、15、22(冬至)23、*31\n \n \n \n \n \n '),COLOR00FFFF,ALIGN5;
DRAWTEXTEX(c,1,1,10,'板块:'+BLKNAME),COLORYELLOW;
DRAWTEXTEX(c,1,1,60,'总股本:'+NUMTOSTR(FINANCE(1)/10000 ,2 )+'亿'+' 流通A股:'+ NUMTOSTR(FINANCE(7)/10000,2)+'亿'),COLORYELLOW;
DRAWTEXTEX(c,1,1,110,
'每股收益:'+ NUMTOSTR(FINANCE(33),2)+' 市盈率:'+NUMTOSTR(DYNAINFO(39),2)+' 净资产:'+NUMTOSTR(FINANCE(34),2)+' 净资产收益率:'+NUMTOSTR(FINANCE(37),2)),COLORYELLOW;
DRAWTEXTEX(c,1,1,160,'上涨家数:'+NUMTOSTR(INDEXADV,0)+' 下跌家数:'+NUMTOSTR(INDEXDEC,0)),COLORYELLOW;
{DRAWTEXTEX(c,1,1,160,'主营业务增长率:'+NUMTOSTR(FINANCE(53),2 )+'%'+' 税后利润增长率:'+NUMTOSTR(FINANCE(54),2 )+'%'+' 净资产增长率:'+NUMTOSTR(FINANCE(55),2 )+'%'),COLOR808080;}
DRAWTEXTEX(c,1,1,210,'五日换手:'+NUMTOSTR(SUM(((VOL/CAPITAL)*100),5),2)+' 五日涨跌:'+NUMTOSTR((c-ref(c,5))/ref(c,5)*100,2)+'%'),COLORYELLOW;
DRAWTEXTEX(c,1,1,260,'获利比率:'+NUMTOSTR(WINNER(c)*100,2)+'%'+' 20华泰对强度:'+NUMTOSTR(c/ref(c,20)/(indexc/ref(indexc,20)),2)),COLORYELLOW;
DRAWTEXTEX(c,1,1,350,'阻力2:'+NUMTOSTR(((ref(h,1)+ref(l,1)+ref(o,1)+ref(c,1))/4+(ref(h,1)-ref(l,1))),2)
+' ('+NUMTOSTR(ref(c,1)+(ref(h,1)-ref(l,1)),2)+')'),COLORYELLOW;
DRAWTEXTEX(c,1,1,400,'阻力1:'+NUMTOSTR(((ref(h,1)+ref(l,1)+ref(o,1)+ref(c,1))/4*2-ref(l,1)),2)+' (昨最高价:'+NUMTOSTR(ref(h,1),2)+')'),COLORYELLOW;
DRAWTEXTEX(c,1,1,450,'支撑1:'+NUMTOSTR(((ref(h,1)+ref(l,1)+ref(o,1)+ref(c,1))/4*2-ref(h,1)),2)+' (昨最低价:'+NUMTOSTR(ref(l,1),2)+')'),COLORYELLOW;
DRAWTEXTEX(c,1,1,500,'支撑2:'+NUMTOSTR(((ref(h,1)+ref(l,1)+ref(o,1)+ref(c,1))/4-(ref(h,1)-ref(l,1))),2)
+' ('+NUMTOSTR(ref(c,1)-(ref(h,1)-ref(l,1)),2)+')'),COLORYELLOW;

指导线: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),linethick1,ColorFFffFF;
界: MA(CLOSE,27),linethick1,Color00FFFF;
DRAWTEXT(CROSS(指导线,界),界,'↑★'),ALIGN1,colorred;//,VALIGN0
DRAWTEXT(CROSS(界,指导线),界,'↓★'),ALIGN1,colorcyn;

DRAWTEXT(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),LOW*0.99,'←B') , COLORRED;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.008,'←S')COLORRED;

WR1:=100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10));
WR2:=100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6));
DRAWTEXT(WR1>90 AND WR1=WR2,L,'威廉');

DRAWICON(CROSS(MA(C,1),MA(C,5)),L,1);

半分位:=REF((HIGH+LOW)/2,1),COLORYELLOW;
STICKLINE(半分位,半分位,半分位,4,1),COLORyellow,LINETHICK1;
//DRAWTEXT((ISLASTBAR = 1),半分位,(' ▲半:' + NUMTOSTR(半分位,2))),ALIGN1,colorgreen;


我自己用的组合MA

  >>>请使用本站搜索功能将找到更多相关自用的组合MA公式下载 飞狐组合指标 源码

下载地址

点这开始下载

精品股票公式

网友评论温馨提示:任何网友发表的言论必须符合国家法律,否则予以删除!

   评论摘要(共有好评 149 条) 请登陆或注册后再发表评论!

     

      验证码:

下载注意

  • 第一股票公式网发布的股票公式主要来源于各大股票论坛,在此谢谢各位老师无私分享原创公式。
  • 引入公式如发现公式名称栏空白,可能是公式使用期限已过。请尝试调整电脑时间到1997年,看能否如正常显示。
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果您发现下载链接错误,请联系管理员报告错误。
  • 第一股票公式网欢迎各位股友帮忙宣传转发本站资源,有您的支持,我们会做得更好!

猜你喜欢

网友爱看

学了又学