第一股票公式网,股票公式,股票,公式下载,指标公式 设为首页加入收藏
你的位置:第一股票公式网通达信公式预测高低大智慧主图指标下载 通达信源码预测

预测高低大智慧主图指标下载 通达信源码预测

  • 公式类型:通达信公式
  • 推荐星级:
  • 公式安全:已通过5款杀毒软件查杀,请放心下载!
  • 更新时间:2018-12-06 16:03:19
  • 相关标签:源码
  • 运行环境: WinXP/Win7/Win8/Win10/Win All
  • 公式语言:用简体中文编写

预测高低大智慧主图指标下载 通达信源码预测详细说明

第一股票公式网(www.chnmoney.com)告诉您:当前正要下载:预测高低大智慧主图指标下载 通达信源码预测

DRAWGBKLAST(1,STRIP(RgB(10,10,50),RGB(50,10,10),0)); MA3:MA(CLOSE,3);
MA4:MA(CLOSE,4); MA5:MA(C,5),colorwhite;MA10:MA(C,10),COLORYELLOW; 警报:=CROSS(MA4,MA3);DRAWTEXT(警报,H*1.05,'↓'),LINETHICK6,ALIGN1,COLORFFFFFF;安全:=CROSS(MA3,MA4);DRAWTEXT(安全,L*0.95,'↑'),LINETHICK6,ALIGN1,colorRED; SD:=HHV(HIGH,13)=HIGH AND HIGH>REF(HIGH,1);
{17}
x9:FORCAST(c,9),Colorwhite,LINETHICK2;
llx:=llv(FORCAST(c,9),2);
PARTLINE(x9,x9=llx,rgb(255,205,0),x9<>llx,rgb(255,0,0)),linethick3;
MA21:MA(C,21),LINETHICK1,COLORE66878; VC:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日突破:=VC+(HIGH-LOW);
明日反转:=VC-(HIGH-LOW);
DRAWTEXTABS(15,71,'明日突破: '+NUMTOSTRN(明日突破,2)+' 元'),COLOR0000FF;
DRAWTEXTABS(15,90,'明日反转: '+NUMTOSTRN(明日反转,2)+' 元'),COLORffff00;
HHVALL(HIGH)*1.1,COLOR000000;
LLVALL(LOW)*0.9,COLOR000000;
{预测当天最低价指标}
A1:=REF(O,1);
A2:=ABS((REF(C,1)-A1)/A1);
A3:=ABS((REF(H,1)-A1)/A1);
A4:=ABS((REF(L,1)-A1)/A1);
B1:=ABS((A2+A3+A4)/3);
B2:=O*B1;
今日最高:=O+B2;
预测低一:O-B2,linethick0;
{预测当天收盘价指标}
开盘价1:=open;
开盘价2:=REF(open,1);
最高价1:=high;
最高价2:=REF(high,1);
最低价1:=low;
最低价2:=REF(low,1);
收盘价1:=CLOSE;
收盘价2:=REF(CLOSE,1);
AA:=最高价2;
BB:=最低价2;
CC:=开盘价2;
DD:=收盘价2;
EE:=(AA+BB+CC+2*DD)/5;
AAA:=EE+(AA-BB);
BBB:=2*EE-BB;
CCC:=2*EE-AA;
DDD:=EE-(AA-BB);
上升突破价:=AAA;
上升阻力价:=BBB;
下跌支撑价:=CCC;
下跌反转价:=DDD;
EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5;
心理价:=EEE;
FFF:=(EEE+开盘价1)/2;
GGG:=(预测低一+FFF)/2;
预测低二:GGG,colorffffff,LINETHICK0;
高:=今日最高;
收:=FFF;

DRAWTEXTABS(15,35,'预测低一: '+NUMTOSTRN(预测低一,2)+'元'),COLORWHITE ,linethick1;

DRAWTEXTABS(15,53,'预测低二: '+NUMTOSTRN(预测低二,2)+'元'),COLORWHITE ,linethick1;
a:="LTFunc5@FORLT2";
s1:="LTFunc5@LT_S1";
p1:="LTFunc5@LT_P1";
drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;
drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;
drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0;
drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2;
{一品资料说明}
WW:=BARSLAST(DISPSTATUS=1);
低涨:(C/LLV(LOW,WW)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;
天:BARSLAST(L=LLV(LOW,WW)),COLOR00FFFF,LINETHICK0,PRECIS0;
DRAWTEXTABS(210,15,'◇低点至今上涨:'+NUMTOSTRN(低涨,2)+'% '+NUMTOSTRN(天,0)+'天'),COLOR0000FF;
DRAWTEXTABS(210,32,'◇目前可见K线:'+NUMTOSTRN(WW+1,0)+'天'),COLORYELLOW;

DRAWTEXTABS(15,15,'预测今日最高价: '+NUMTOSTRN(ref(今日最高,0),2)+'元'),COLORF00FF0,linethick1;
DRAWTEXTREL(680,950,'预测今日收盘价: '+NUMTOSTRN(ref(FFF,0),2)+'元'),COLORF00FF0,linethick1;
{43}
DRAWGBK(c,'7' );
Var3:=LLV(H,240);
Var4:=100*(C-Var3)/Var3;
Var5:=(C-LLV(L,528))/(HHV(H,528)-LLV(L,528))*100;
Var6:=(C-LLV(C,530))/(HHV(C,530)-LLV(C,530))*100;
{Var7:=0;}
Var8:=MA(HHV(C-REF(C,1),0),34)/MA(ABS(C-REF(C,1)),7)*100;
Var9:=MA(HHV(C-REF(C,1),0),13)/MA(ABS(C-REF(C,1)),13)*100;
VarA:=BARSCOUNT(C);
VarB:=Var8<20 AND Var9<23 AND VarA>35;
VarC:=VarB AND COUNT(VarB,1)=1;
VarD:=EMA(C,21)-EMA(C,8);
VarE:=EMA(VarD,5);
VarF:=TROUGH(3,6,1)<4 AND CROSS(VarD,VarE);
Var10:=IF(TROUGH(3,16,1)=0 AND H>L+0.04,4,0);
Var11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
Var12:=ZIG(3,6)<REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
Var13:=ZIG(3,22)>REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
Var14:=ZIG(3,22)<REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
Var15:=ZIG(3,51)>REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
Var16:=ZIG(3,51)<REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2)AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
Var17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
Var18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
Var19:=EMA(C,2)-EMA(C,150);
Var1A:=EMA(Var19,100);
Var1B:=2*(Var19-Var1A);
Var1C:=POW(Var1B,3)*0.1+POW(Var1B,1);
Var1D:=SQRT(SQRT(L*H*O*C));
Var1E:=EMA(Var1D*0.97,3);
Var1F:=(H+L+C)/3;
Var20:=(Var1F-MA(Var1F,14))/(0.015*AVEDEV(Var1F,14));
Var21:=CROSS(Var1E,L);
买点1:=Var10;
买点2:=(Var11+Var13+Var15+Var17);
卖点1:=(Var12+Var14+Var16+Var18);
Var22:=买点1 AND VarF AND VarC AND Var21 AND Var4<0AND Var5=0 AND Var6=0 AND Var20<(-110);
DRAWTEXT(买点1>0,L-0.15,'B'),LINETHICK4,ALIGN1,colorred;{B}
DRAWTEXT(买点2>0,L-0.25,{'B'}'买'),LINETHICK2,ALIGN1,COLOR00FFFF;{B}
DRAWTEXT(卖点1>0,H+0.95,{'S'}'卖'),LINETHICK2,ALIGN1,COLOR33FF33;{S}
闪:EMA(c+(h-l)*0.618,3),Color0099FF,LINETHICK0;进:EMA((o+h+l)/3,4),COLORCYAN,LINETHICK0;
预测明日买点:=EMA((o+h+l)/3,4)+((h+l)/2-ref((o+h+l)/3,3))/4;
DRAWTEXTREL(250,0,' ◇测今日低点:'+NUMTOSTRN(ref(预测明日买点,1),2 )),ColorGREEN,linethick1;
预测明日卖点:=EMA(c+(h-l)*0.618,3)+(EMA(c+(h-l)*0.618,3)-进)*0.618;
DRAWTEXTREL(15,0,'♂ 测今日高点:'+NUMTOSTRN(ref(预测明日卖点,1),2 )),Colorred,linethick1;{预测明日涨跌}
C1:=REF(CLOSE,1);
C2:=HHV(C1,2);
C3:=LLV(C1,1);
ET:=HHV(C1,2);
ET1:=REF(ET,1);
XB:=LLV(C1,1);
XB1:=REF(XB,1);
M:=BARSLAST(((CLOSE < XB) AND (C1 >= XB1)));
M11:=REF(M,1);
N9:=BARSLAST(((CLOSE > ET) AND (C1 <= ET1)));
N1:=REF(N9,1);
M21:=(BARSLAST((((M - N9) > 0) AND (M11 <= N1))) + 1);
N2:=(BARSLAST((((N9 - M) > 0) AND (N1 <= M11))) + 1);
ET2:=HHV(ET,M21);
XB2:=LLV(XB,N2);
A:=IF((((M - N9) > 0) AND (M11 <= N1)),1,IF((((N9 - M) > 0) AND (N1 <= M11)),0,2));
H1:=IF(((M - N9) > 0),CLOSE,ET2);
H2:=IF((A = 1),CLOSE,C2);
H3:=IF(((M - N9) < 0),CLOSE,XB2);
H4:=IF((A = 1),CLOSE,XB2);
H5:=IF((((M - N9) > 0) OR (A = 1)),CLOSE,H3);
H6:=REF(H5,1);
H7:=REF(H5,2);
H8:=(H5 > H6);
H9:=(((H4 = REF(H4,1)) AND (REF(H4,1) < REF(H4,2))) AND (H5 > REF(H5,2)));
H10:=(((H2 = REF(H2,1)) AND (H4 = REF(H4,1))) AND (H5 = REF(H5,2)));
W:=((H8 OR H9) OR H10);
T9:=((H5 < H6) AND (H5 < REF(H5,2)));
T10:=((H4 = REF(H4,1)) AND (H5 < REF(H5,2)));
T11:=((H3 > REF(H3,1)) AND (H5 < REF(H5,1)));
T12:=((H5 = REF(H5,1)) AND (H3 = H4));
T13:=((H2 = REF(H2,1)) AND (H2 = H5));
TW:=((((T9 OR T10) OR T11) OR T12) OR T13);
PK:=((AMOUNT * (((OPEN + CLOSE) + HIGH) + LOW)) / 4);
PK1:=IF((VOL > 0),(PK / AMOUNT),((((OPEN + CLOSE) + HIGH) + LOW) / 4));
BBP:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
DRAWTEXT(((DISPSTATUS=2 AND W) AND (BBP < 96.5)),(H5 * 1.022),' 明日 看涨'),MOVE1,colorFF00ff;
DRAWTEXT(((DISPSTATUS=2 AND TW) AND (BBP > 1)),((H5 + H4) / 2),' 明日 看跌'),MOVE0,colorffFF00;{支撑压力}
gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
STICKLINE(DISPSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,30,0),Color0000FF;
STICKLINE(DISPSTATUS=2 and c<今日阻力,今日阻力,今日阻力,30,0),Color00FF00;
STICKLINE(DISPSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,30,0),ColorFF00FF;
STICKLINE(DISPSTATUS=2 and c<今日支撑,今日支撑,今日支撑,30,0),ColorFF0000;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
aRSV:=SMA(下档线,3,1);
aK:=SMA(aRSV,3,1);
aD:=((3 * aRSV) - (2 * aK));
aJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
aRSV24:=SMA(aJ12,3,1);
aK24:=SMA(aRSV24,3,1);
aD24:=((3 * aRSV24) - (2 * aK24));
撑压位:=IF(CROSS(aD24,aD),HIGH,REF(HIGH,BARSLAST(CROSS(aD24,aD)))){,LINETHICK2,COLORFFFFFF};
底:=LLV(HIGH,30){,COLOR00FF00,LINETHICK2};
STICKLINE(BARSTATUS=2 ,撑压位,撑压位,30,1),LINETHICK1,COLORFFFFFF;
DRAWTEXT(BARSTATUS=2 ,撑压位,' 撑压'),COLORFFFFFF,VALIGN1;
STICKLINE(BARSTATUS=2 ,底,底,30,1),COLOR00FF00,LINETHICK1;
DRAWTEXT(BARSTATUS=2 ,底,' 底线'),COLOR00FF00,VALIGN0;


预测高低(大智慧 源码 主图 贴图)

  >>>请使用本站搜索功能将找到更多相关预测高低大智慧主图指标下载 通达信源码预测

下载地址

点这开始下载

精品股票公式

网友评论温馨提示:任何网友发表的言论必须符合国家法律,否则予以删除!

   评论摘要(共有好评 119 条) 请登陆或注册后再发表评论!

     

      验证码:

下载注意

  • 第一股票公式网发布的股票公式主要来源于各大股票论坛,在此谢谢各位老师无私分享原创公式。
  • 引入公式如发现公式名称栏空白,可能是公式使用期限已过。请尝试调整电脑时间到1997年,看能否如正常显示。
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果您发现下载链接错误,请联系管理员报告错误。
  • 第一股票公式网欢迎各位股友帮忙宣传转发本站资源,有您的支持,我们会做得更好!

猜你喜欢

网友爱看

学了又学