第一股票公式网,股票公式,股票,公式下载,指标公式 设为首页加入收藏
你的位置:第一股票公式网通达信公式周K线副图附图完美分享指标下载 通达信源码完美

周K线副图附图完美分享指标下载 通达信源码完美

  • 公式类型:通达信公式
  • 推荐星级:
  • 公式安全:已通过5款杀毒软件查杀,请放心下载!
  • 更新时间:2019-01-11 07:14:26
  • 相关标签:完美
  • 运行环境: WinXP/Win7/Win8/Win10/Win All
  • 公式语言:用简体中文编写

周K线副图附图完美分享指标下载 通达信源码完美详细说明

第一股票公式网(www.chnmoney.com)告诉您:当前正要下载:周K线副图附图完美分享指标下载 通达信源码完美

要先建好第一个OCHL的公式,再建第二个周K线副图公式,发的源码是分开的两个公式.已经装在我的软件里试用过,我用的是招商证券的通达信软件,用广发证券的也可以,另外要下载好日线数据


先建一引用指标副图,名为:OCHL
ND1970:=(YEAR-1970)*365+INTPART((YEAR-1972)/4)-IF(INTPART(YEAR/4)=YEAR/4,1,0)+DAY+(MONTH-1)*30+IF(MONTH<=8,INTPART(MONTH/2),INTPART((MONTH-7)/2)+4)-IF(MONTH>2 AND INTPART(YEAR/4)=YEAR/4,1,IF(MONTH>2 AND NOT(INTPART(YEAR/4)=YEAR/4),2,0));
C1:C;
O1:REF(O,BARSLAST(ND1970-REF(ND1970,1)>WEEKDAY-REF(WEEKDAY,1)));
H1:HHV(H,BARSLAST(ND1970-REF(ND1970,1)>WEEKDAY-REF(WEEKDAY,1))+1);
L1:LLV(L,BARSLAST(ND1970-REF(ND1970,1)>WEEKDAY-REF(WEEKDAY,1))+1);

再建一指标,名为:周K线副图,源码为:
WO1:="OCHL.O1#WEEK";
WC:="OCHL.C1#WEEK";
WH:="OCHL.H1#WEEK";
WL:="OCHL.L1#WEEK";
K1:=WO1=REF(WO1,1) AND WC=REF(WC,1) AND WH=REF(WH,1) AND WL=REF(WL,1);
K3:=REF(C,1)=DYNAINFO(3) AND O=DYNAINFO(4) AND C=DYNAINFO(7) AND H=DYNAINFO(5) AND L=DYNAINFO(6);
DD:=REF(BARSLAST(K1=0)+1,1),LINETHICK0;
DD1:=CROSS(BACKSET((K1=0 OR K3) AND DD=5,4),0.5),NODRAW;
DD2:=CROSS(BACKSET((K1=0 OR K3) AND (DD=4 OR DD=3),3),0.5),NODRAW;
DD3:=CROSS(BACKSET((K1=0 OR K3) AND DD<=2,2),0.5),LINETHICK0;
BK1:=DD1 OR DD2 OR DD3;
BK2:=CROSS(BACKSET(K1=0,2),0.5);
BK3:=CROSS(BACKSET(K1=0 AND REF(K1=0,1),2),0.5);
WO:IF(BARSLAST(K1=0)=0,O,REF(O,BARSLAST(K1=0))),NODRAW;
K0:=WC>WO OR (WC=WO AND WC>REF(WC,BARSLAST(K1=0)+1));
STICKLINE(K0 AND BK1,WH,WC,0,0),COLORLIMAGENTA;
STICKLINE(K0 AND BK1,WO,WL,0,0),COLORLIMAGENTA;
STICKLINE(K0 AND K1=0,WC,WO,0,0),COLORLIMAGENTA;
STICKLINE(K0 AND (BK2 OR K3),WC,WO,0,0),COLORLIMAGENTA;
STICKLINE(K0 AND ((K1 AND BK2=0 AND K3=0) OR BK3),WC,WC,8,1),COLORLIMAGENTA;
STICKLINE(K0 AND ((K1 AND BK2=0 AND K3=0) OR BK3),WO,WO,8,1),COLORLIMAGENTA;
STICKLINE(NOT(K0) AND BK1,WH,WO,0,0),COLORCYAN;
STICKLINE(NOT(K0) AND BK1,WC,WL,0,0),COLORCYAN;
STICKLINE(NOT(K0) AND K1=0,WC,WO,0,0),COLORCYAN;
STICKLINE(NOT(K0) AND (BK2 OR K3),WC,WO,0,0),COLORCYAN;
STICKLINE(NOT(K0) AND ((K1 AND BK2=0 AND K3=0) OR BK3),WC,WC,8,1),COLORCYAN;
STICKLINE(NOT(K0) AND ((K1 AND BK2=0 AND K3=0) OR BK3),WO,WO,8,1),COLORCYAN;
MA1:MA(C,20),COLORWHITE;
MA2:MA(C,60),COLORYELLOW;
MA3:MA(C,120),COLORMAGENTA;


通达信周K线副图,完美分享,有图有源码

  >>>请使用本站搜索功能将找到更多相关周K线副图附图完美分享指标下载 通达信源码完美

下载地址

点这开始下载

精品股票公式

网友评论温馨提示:任何网友发表的言论必须符合国家法律,否则予以删除!

   评论摘要(共有好评 126 条) 请登陆或注册后再发表评论!

     

      验证码:

下载注意

  • 第一股票公式网发布的股票公式主要来源于各大股票论坛,在此谢谢各位老师无私分享原创公式。
  • 引入公式如发现公式名称栏空白,可能是公式使用期限已过。请尝试调整电脑时间到1997年,看能否如正常显示。
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果您发现下载链接错误,请联系管理员报告错误。
  • 第一股票公式网欢迎各位股友帮忙宣传转发本站资源,有您的支持,我们会做得更好!

猜你喜欢

网友爱看

学了又学