第一股票公式网,股票公式,股票,公式下载,指标公式 设为首页加入收藏
你的位置:第一股票公式网通达信公式私募趋势操盘主图附图此主图亲自测试过也能够用于手机版指标下载

私募趋势操盘主图附图此主图亲自测试过也能够用于手机版指标下载

  • 公式类型:通达信公式
  • 推荐星级:
  • 公式安全:已通过5款杀毒软件查杀,请放心下载!
  • 更新时间:2020-01-13 08:37:13
  • 相关标签:私募趋势操盘主图
  • 运行环境: WinXP/Win7/Win8/Win10/Win All
  • 公式语言:用简体中文编写

私募趋势操盘主图附图此主图亲自测试过也能够用于手机版指标下载详细说明

第一股票公式网(www.chnmoney.com)告诉您:当前正要下载:私募趋势操盘主图附图此主图亲自测试过也能够用于手机版指标下载

私募趋势操盘主图附图此主图亲自测试过也能够用于手机版指标源码下载:

 私募趋势操盘主图
 

 手机公式源码,亲自测试过的,源码很长,很费时间。
 

 电脑版本的源码:
{私募趋势操盘主图}
DIR2:=ABS(CLOSE-REF(CLOSE,30));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),30);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
M熊:=EMA(DMA(CLOSE,CQ2),2),COLORGREEN,LINETHICK1;
FF1:=C>M熊 AND M熊>REF(M熊,1),NODRAW;
FF2:=C<M熊 AND M熊<=REF(M熊,1);
Q1:=CONST(IF(FF1,200,IF(FF2,0,DRAWNULL)));
Q2:=CONST(IF(FF1,0, IF(FF2,20,DRAWNULL)));
Q3:=CONST(IF(FF1,00, IF(FF2,0,DRAWNULL)));
{DRAWGBK(C>0,RGB(Q1,Q2,Q3),RGB(0,120,120),0,' ',0);}
牛熊分界线:EMA(DMA(CLOSE,CQ2),2),COLOR0050FF,LINETHICK0;
牛熊:=M熊;
M震:=IF(M熊/REF(M熊,1)>0.997,M熊,DRAWNULL),COLORBLUE,LINETHICK2;
M牛:=IF(M熊/REF(M熊,1)>1.001,M熊,DRAWNULL),COLORRED,LINETHICK2;
XX1:=C>牛熊 AND 牛熊>REF(牛熊,1);
DRAWTEXT_FIX(ISLASTBAR AND XX1,0.76,0.00,0,'【处于牛区】'),COLORRED;
XX2:=C<牛熊 AND 牛熊<=REF(牛熊,1);
DRAWTEXT_FIX(ISLASTBAR AND XX2,0.76,0.00,0,'【处于熊区】'),COLOR33AAAA;
{钻石}
AQ1:=REF(V,1);AQ2:=DVOL;AQ3:=AQ2/AQ1;
LNX:=AQ3-REF(AQ3,1);
E1:=REF(C,1);E2:=DCLOSE;E3:=(E2-E1)/E1*100;
QMX:=E3-REF(E3,1);
XG:=CROSS(LNX,500) AND CROSS(QMX,10);
DRAWTEXT(XG=1,L*0.995,' '),COLORFFCC88;
DRAWICON(XG=1,L*0.993,25);
VAR1:=(C+H+O+L)/4;
卖出:XMA(VAR1,20)*(1+80/1000),COLORGREEN,LINETHICK2;
买入:XMA(VAR1,32)*(1-100/1000),COLORRED,LINETHICK2;
幅度:100*(卖出-买入)/买入,NODRAW;
{第一股票公式网-最好的股票公式网站 www.cHnMoNey.Com}
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),3,0),COLORRED;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),3,0),COLORRED;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORRED;
STICKLINE(买入>HIGH,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORRED;
DRAWTEXT(CROSS(LOW,买入),LOW*0.95,'←流入'),COLORMAGENTA,LINETHICK2;
DRAWTEXT(CROSS(卖出,HIGH),HIGH*1.02,'←流出'),COLORYELLOW;
EXP1:EXPMA(CLOSE,10),NODRAW;
EXP2:EXPMA(CLOSE,60),NODRAW;
ZT:=C/REF(C,1)>1.097;
DRAWTEXT(ZT,L*0.98,'涨停'),COLOR00FFFF;
DRAWICON(ZT,L*0.99,1);
STICKLINE(ZT,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(ZT,H,L,0,0),COLORRED;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
阳涨幅:=4;
阳倍量:=2;
单阳:=C>O*(1+阳涨幅/100) AND VOL>REF(VOL,1)*阳倍量 AND C/REF(C,1)<1.097;
DRAWTEXT(单阳,L*0.98,'大阳'),COLORFF00FF;
STICKLINE(单阳,O,C,1.5,0),COLORFF00FF;
生命线:=MA(C,60);
牛熊线:=MA(C,120);
V1:=(C+H+L)/3;
MA3:=MA(V1,2);
MA5:=MA(V1,5);
DRAWBAND(MA2,RGB(200,50,55),MA5,RGB(0,100,50));
{天使主图}
VAR6:=(( ABS((OPEN-CLOSE))/(HIGH-LOW))*VOL);
VAR7:=(( (HIGH-IF((CLOSE>OPEN),CLOSE,OPEN))/(HIGH-LOW))*VOL);
VAR8:=(( (IF((CLOSE>OPEN),OPEN,CLOSE)-LOW)/(HIGH-LOW))*VOL);
VAR9:=IF(((VOL/CAPITAL)>0.001),1,EXP(ABS(LOG(((VOL/CAPITAL)*100)))));
加仓:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN,NODRAW,COLORRED;
减仓:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN,NODRAW,COLORBLUE;
洗盘:VAR8>VAR6 AND VAR8>VAR7,NODRAW,COLORWHITE;
高抛:VAR7>VAR6 AND VAR7>VAR8,NODRAW,COLORMAGENTA;
地量:VAR9>2 AND VOL<MA(VOL,5)/2,NODRAW,COLORGREEN;
DRAWKLINE(H,O,L,C);
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
前期高位:REF(H,BARSLAST(HD)), COLORFF00FF,POINTDOT,LINETHICK3;
前期低位:REF(L,BARSLAST(LD)), COLORGREEN,POINTDOT,LINETHICK3;
STICKLINE(加仓,O,C,1,0),COLORRED;
STICKLINE(洗盘,O,C,1,0),COLORWHITE;
STICKLINE(减仓,O,C,1,0),COLORBLUE;
STICKLINE(高抛,O,C,1,0),COLORMAGENTA;
STICKLINE(地量,O,C,1,0),COLORGREEN;
JJ:=(3*C+H+L+O)/6;
VARB1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VARB1 AND C>REF(C,1);
LJL:=FILTER(TJ1,5);
STICKLINE(CLOSE,REF(LOW,BARSLAST(LJL)),REF(LOW,BARSLAST(LJL)),1,0),COLORRED;
STICKLINE(CLOSE,REF(CLOSE,BARSLAST(LJL)),REF(CLOSE,BARSLAST(LJL)),1,0),COLORYELLOW;
STICKLINE(LJL,OPEN,CLOSE,1,0),COLORYELLOW;
DRAWTEXT_FIX(1,0.0,0.0,0,'蓝芯-主力低位深度洗盘或高位出货坚决'),COLORBLUE,LINETHICK1;
DRAWTEXT_FIX(1,0.00,0.06,0,'白芯-主力轻度洗盘'),COLORWHITE,LINETHICK1;
DRAWTEXT_FIX(1,0.00,0.12,0,'棕芯-出现了近期相对地量'),COLORGREEN,LINETHICK1;
DRAWTEXT_FIX(1,0.00,0.18,0,'粉芯-主力在做高抛低吸或低吸高抛'),COLORFF00FF,LINETHICK1;
DRAWTEXT_FIX(1,0.00,0.24,0,'红芯-主力吸筹进货积极主动'),COLORRED,LINETHICK1;
DRAWTEXT_FIX(1,0.00,0.3,0,'黄芯-主力吸筹进货强并且成交量出现黄金柱'),COLORYELLOW,LINETHICK1;
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
走强2:=BARSLAST(PL10<REF(PL10,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
追2:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
追4:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3;
DRAWTEXT(追2 OR 追4,LOW*0.978,'追'),COLORYELLOW;
PL5:=ZIG(3,5);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
{ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);}
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'反弹低点'),COLORLIRED;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'反弹高点!'),COLORLIBLUE;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'底'),COLORYELLOW;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'↙减仓'),COLORFFFF00;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'----买'),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'短卖'),COLORGREEN;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'----短买'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'短卖'),COLORGREEN;
DRAWTEXT(EN2 AND DTJZ10=1,L*0.96,'Ⅰ'),COLORFF00FF;
DRAWTEXT(EX2 AND DTJD10=2,H*1.03,'Ⅱ'),COLORFF6000;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'Ⅲ'),COLORYELLOW;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.06,'①'),LINETHICK3,COLORFFFF00;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.96,'②'),LINETHICK3,COLORYELLOW;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.02,'   '),LINETHICK3,COLORWHITE;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.96,'④'),LINETHICK3,COLORYELLOW;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.95,'⑷'),COLORYELLOW;
EMA13:=EMA(C,13);
EMA34:=EMA(C,34);
EMA55:=EMA(C,55);
EMA120:=EMA(C,120);
CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
CR2:=V>MA(V,5)*0.6;
CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;
CR4:=ABS(EMA34-EMA55)/EMA55<0.03;
CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);
CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
DRAWTEXT(CR6,C*0.98,'风险'),COLORCYAN;
{捞钱手}
MMS:=MA(SMA((L+H+2*C)/4-REF((L+H+2*C)/4,1),5,1)/SMA(ABS((L+H+2*C)/4-REF((L+H+2*C)/4,1)),5,1)*100,1)+50;
G1:=IF(-MMS>95,0,20);
UOO:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0 AND G1)+1);
KS:=(((CLOSE-EMA(CLOSE,13))/EMA(CLOSE,13))*(0-100));
KS1:=IF(BARSCOUNT(C)=1,C/10000,(1-C/SMA(C,13,1))*100);
趋势线:=EMA(((KS/10)+EMA(CLOSE,10)),3);
AA:=-100*(趋势线-CLOSE)/趋势线;
AC:=(EMA(AA,5));
SSL:=EMA(CLOSE,3);
MMV:=EMA(((SLOPE(CLOSE,22)*20)+CLOSE),55);
MM:=MA(MMV,1);
SA:=(MM*0.985);
SS:=(MA(CLOSE,5));
DD:=(MA(CLOSE,13));
GG:=(MA(CLOSE,21));
能量线:=DMA(((CLOSE+OPEN)/2),(VOL/(SMA(VOL,4,1)*4)));
上开:=O;
上收:=C;
上高:=H;
上低:=L;
JJ2:=(上开+上高+上低)/3;
A:=EMA(JJ2,4);
B:=REF(A,1);
VA1:=EMA(上收,8);
VA2:=EMA(上收,20);
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.978,'  '),LINETHICK2,COLORBBBBBB;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'↙卖出'),COLORWHITE;
{庄家机密}
DATA:=5;
{多头买入} DRAWICON(ZIG(3,DATA)>REF(ZIG(3,DATA),1)
AND REF(ZIG(3,DATA),1)<=REF(ZIG(3,DATA),2)
AND REF(ZIG(3,DATA),2)<=REF(ZIG(3,DATA),3),L*0.97,1);
{多头卖出} DRAWICON(ZIG(3,DATA)<REF(ZIG(3,DATA),1)
AND REF(ZIG(3,DATA),1)>=REF(ZIG(3,DATA),2)
AND REF(ZIG(3,DATA),2)>=REF(ZIG(3,DATA),3),H*1.05,2);
AAA1:=STRCAT('沪深总上涨家数:',CON2STR(DYNAINFO(60),0));
AAA2:=STRCAT('沪深总下跌家数:',CON2STR(DYNAINFO(61),0));
DRAWTEXT_FIX(ISLASTBAR,0.00,0.72,0,AAA1),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.00,0.67,0,AAA2),COLORGREEN;
字:=STRCAT(STRCAT(STRCAT(STRCAT('名称:',STKNAME),' 代码: '),CODE),' ' );
板块:=STRCAT('概念板块: ',GNBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0.00.2,0.895,0,STRCAT(字,板块)),COLOR11BB88;
DRAWTEXT_FIX(1,0.001,0.31,0,'  '),COLORCYAN;
DRAWTEXT_FIX(1,0.07,0.84,0,FGBLOCK),COLOR228888;
DRAWTEXT_FIX(1,0.00,0.84,0,DYBLOCK),COLORCYAN;
{同花顺概念主营业务}
DRAWTEXT_FIX(1,0.00,0.73,0,'')COLORWHITE;{概念:}
DRAWTEXT_FIX(1,0.04,0.73,0,EXTERNSTR(0,2))COLOR44AAAA;
DRAWTEXT_FIX(1,0.00,0.895,0,' ')COLORGREEN;{主营业务:}
DRAWTEXT_FIX(1,0.07,0.895,0,EXTERNSTR(0,1))COLOR0090FF;
{自定义板块}
DRAWTEXT_FIX(C>O,0.00,0.97,0,'自定:'),COLORFF00FF;
DRAWTEXT_FIX(1,0.040,00.97,0,STRCAT('',ZDBLOCK)),COLORYELLOW;
DRAWTEXT_FIX(1,0.00,0.78,0,'解禁日期:  ')COLORGREEN;
DRAWTEXT_FIX(1,0.06,0.78,0,EXTERNSTR(0,666)),COLOR00FF00,LINETHICK2;
{显示日期}
D1:=YEAR AND MONTH AND DAY;
AA1:=STRCAT(CON2STR(YEAR,0),'年');
AA2:=STRCAT(CON2STR(MONTH,0),'月');
AA3:=STRCAT(CON2STR(DAY,0),'日');
AA4:=STRCAT('星期',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日')))))));
AB:=STRCAT(STRCAT(STRCAT(AA1,AA2),STRCAT(AA3,AA4)),'');
DRAWTEXT_FIX(D1,0.85,0,0,AB),COLOR33AAAA;
{牛指标}
VADR1:=C-REF(C,1);
VADR2:=100*EMA(EMA(VADR1,6),6)/EMA(EMA(ABS(VADR1),6),6);
MAD5:=EMA(C,5);
MAD13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MAD13,MAD5))+1),LLV(L,BARSLAST(CROSS
(MAD13,MAD5))+1),H=HHV(H,BARSLAST(CROSS(MAD5,MAD13))+1),HHV(H,BARSLAST(CROSS
(MAD5,MAD13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MAD5,MAD13))+1),HHV(H,BARSLAST(CROSS
(MAD5,MAD13))+1),L=LLV(L,BARSLAST(CROSS(MAD13,MAD5))+1),LLV(L,BARSLAST(CROSS
(MAD13,MAD5))+1),0),COLOR00FF00;
BT:=(LLV(VADR2,2)=LLV(VADR2,7) AND COUNT(VADR2<0,2) AND CROSS(VADR2,MA(VADR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
DRAWTEXT(BT,C*0.97,'短牛'),COLORFFFFFF;
TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
DRAWTEXT(TJ2,C*0.94,'中牛'),COLORMAGENTA;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
TJ3:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
DRAWTEXT(TJ3,L*0.93,'◆牛牛'),COLORYELLOW;
 

 手机公式源码,通达信手机公式源码
VAR1:=(C+H+O+L)/4;
卖出:XMA(VAR1,20)*(1+80/1000),COLORGREEN,LINETHICK2;
买入:XMA(VAR1,32)*(1-100/1000),COLORRED,LINETHICK2;
幅度:100*(卖出-买入)/买入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),3,0),COLORRED;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),3,0),COLORRED;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORRED;
STICKLINE(买入>HIGH,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORRED;
DRAWTEXT(CROSS(LOW,买入),LOW*0.95,'←流入'),COLORMAGENTA,LINETHICK2;
DRAWTEXT(CROSS(卖出,HIGH),HIGH*1.02,'←流出'),COLORYELLOW;
EXP1:EXPMA(CLOSE,10),NODRAW;
EXP2:EXPMA(CLOSE,60),NODRAW;
ZT:=C/REF(C,1)>1.097;
DRAWTEXT(ZT,L*0.98,'涨停'),COLOR00FFFF;
DRAWICON(ZT,L*0.99,1);
STICKLINE(ZT,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(ZT,H,L,0,0),COLORRED;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
阳涨幅:=4;
阳倍量:=2;
单阳:=C>O*(1+阳涨幅/100) AND VOL>REF(VOL,1)*阳倍量 AND C/REF(C,1)<1.097;
DRAWTEXT(单阳,L*0.98,'大阳'),COLORFF00FF;
STICKLINE(单阳,O,C,1.5,0),COLORFF00FF;
生命线:=MA(C,60);
牛熊线:=MA(C,120);
V1:=(C+H+L)/3;
MA3:=MA(V1,2);
MA5:=MA(V1,5);
{天使主图}
VAR6:=(( ABS((OPEN-CLOSE))/(HIGH-LOW))*VOL);
VAR7:=(( (HIGH-IF((CLOSE>OPEN),CLOSE,OPEN))/(HIGH-LOW))*VOL);
VAR8:=(( (IF((CLOSE>OPEN),OPEN,CLOSE)-LOW)/(HIGH-LOW))*VOL);
VAR9:=IF(((VOL/CAPITAL)>0.001),1,EXP(ABS(LOG(((VOL/CAPITAL)*100)))));
加仓:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN,NODRAW,COLORRED;
减仓:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN,NODRAW,COLORBLUE;
洗盘:VAR8>VAR6 AND VAR8>VAR7,NODRAW,COLORWHITE;
高抛:VAR7>VAR6 AND VAR7>VAR8,NODRAW,COLORMAGENTA;
地量:VAR9>2 AND VOL<MA(VOL,5)/2,NODRAW,COLORGREEN;
DRAWKLINE(H,O,L,C);
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
前期高位:REF(H,BARSLAST(HD)), COLORFF00FF,POINTDOT,LINETHICK3;
前期低位:REF(L,BARSLAST(LD)), COLORGREEN,POINTDOT,LINETHICK3;
STICKLINE(加仓,O,C,1,0),COLORRED;
STICKLINE(洗盘,O,C,1,0),COLORWHITE;
STICKLINE(减仓,O,C,1,0),COLORBLUE;
STICKLINE(高抛,O,C,1,0),COLORMAGENTA;
STICKLINE(地量,O,C,1,0),COLORGREEN;
JJ:=(3*C+H+L+O)/6;
VARB1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VARB1 AND C>REF(C,1);
LJL:=FILTER(TJ1,5);
STICKLINE(CLOSE,REF(LOW,BARSLAST(LJL)),REF(LOW,BARSLAST(LJL)),1,0),COLORRED;
STICKLINE(CLOSE,REF(CLOSE,BARSLAST(LJL)),REF(CLOSE,BARSLAST(LJL)),1,0),COLORYELLOW;
STICKLINE(LJL,OPEN,CLOSE,1,0),COLORYELLOW;
DRAWTEXT_FIX(1,0.0,0.0,0,'蓝芯-主力低位深度洗盘或高位出货坚决'),COLORBLUE,LINETHICK1;
DRAWTEXT_FIX(1,0.00,0.06,0,'白芯-主力轻度洗盘'),COLORWHITE,LINETHICK1;
DRAWTEXT_FIX(1,0.00,0.12,0,'棕芯-出现了近期相对地量'),COLORGREEN,LINETHICK1;
DRAWTEXT_FIX(1,0.00,0.18,0,'粉芯-主力在做高抛低吸或低吸高抛'),COLORFF00FF,LINETHICK1;
DRAWTEXT_FIX(1,0.00,0.24,0,'红芯-主力吸筹进货积极主动'),COLORRED,LINETHICK1;
DRAWTEXT_FIX(1,0.00,0.3,0,'黄芯-主力吸筹进货强并且成交量出现黄金柱'),COLORRED,LINETHICK1;
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
走强2:=BARSLAST(PL10<REF(PL10,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
追2:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
追4:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3;
{第二段}
DRAWTEXT(追2 OR 追4,LOW*0.978,'追'),COLORYELLOW;
PL5:=ZIG(3,5);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
{ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);}
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'反弹低点'),COLORLIRED;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'反弹高点!'),COLORLIBLUE;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'底'),COLORYELLOW;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'减仓'),COLORFFFF00;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'----买'),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'短卖'),COLORGREEN;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'----短买'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'短卖'),COLORGREEN;
DRAWTEXT(EN2 AND DTJZ10=1,L*0.96,'Ⅰ'),COLORFF00FF;
DRAWTEXT(EX2 AND DTJD10=2,H*1.03,'Ⅱ'),COLORFF6000;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'Ⅲ'),COLORYELLOW;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.06,'①'),LINETHICK3,COLORFFFF00;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.96,'②'),LINETHICK3,COLORYELLOW;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.02,'   '),LINETHICK3,COLORWHITE;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.96,'④'),LINETHICK3,COLORYELLOW;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.95,'⑷'),COLORYELLOW;
EMA13:=EMA(C,13);
EMA34:=EMA(C,34);
EMA55:=EMA(C,55);
EMA120:=EMA(C,120);
CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
CR2:=V>MA(V,5)*0.6;
CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;
CR4:=ABS(EMA34-EMA55)/EMA55<0.03;
CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);
CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
DRAWTEXT(CR6,C*0.98,'风险'),COLORCYAN;
{捞钱手}
MMS:=MA(SMA((L+H+2*C)/4-REF((L+H+2*C)/4,1),5,1)/SMA(ABS((L+H+2*C)/4-REF((L+H+2*C)/4,1)),5,1)*100,1)+50;
G1:=IF(-MMS>95,0,20);
UOO:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0 AND G1)+1);
KS:=(((CLOSE-EMA(CLOSE,13))/EMA(CLOSE,13))*(0-100));
KS1:=IF(BARSCOUNT(C)=1,C/10000,(1-C/SMA(C,13,1))*100);
趋势线:=EMA(((KS/10)+EMA(CLOSE,10)),3);
AA:=-100*(趋势线-CLOSE)/趋势线;
AC:=(EMA(AA,5));
SSL:=EMA(CLOSE,3);
MMV:=EMA(((SLOPE(CLOSE,22)*20)+CLOSE),55);
MM:=MA(MMV,1);
SA:=(MM*0.985);
SS:=(MA(CLOSE,5));
DD:=(MA(CLOSE,13));
GG:=(MA(CLOSE,21));
能量线:=DMA(((CLOSE+OPEN)/2),(VOL/(SMA(VOL,4,1)*4)));
上开:=O;
上收:=C;
上高:=H;
上低:=L;
JJ2:=(上开+上高+上低)/3;
A:=EMA(JJ2,4);
B:=REF(A,1);
VA1:=EMA(上收,8);
VA2:=EMA(上收,20);
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.978,'  '),LINETHICK2,COLORBBBBBB;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'
{第三段}
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.978,'  '),LINETHICK2,COLORBBBBBB;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'卖出'),COLORWHITE;
{庄家机密}
DATA:=5;
{多头买入} DRAWICON(ZIG(3,DATA)>REF(ZIG(3,DATA),1)
AND REF(ZIG(3,DATA),1)<=REF(ZIG(3,DATA),2)
AND REF(ZIG(3,DATA),2)<=REF(ZIG(3,DATA),3),L*0.97,1);
{多头卖出} DRAWICON(ZIG(3,DATA)<REF(ZIG(3,DATA),1)
AND REF(ZIG(3,DATA),1)>=REF(ZIG(3,DATA),2)
AND REF(ZIG(3,DATA),2)>=REF(ZIG(3,DATA),3),H*1.05,2);
{牛指标}
VADR1:=C-REF(C,1);
VADR2:=100*EMA(EMA(VADR1,6),6)/EMA(EMA(ABS(VADR1),6),6);
MAD5:=EMA(C,5);
MAD13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MAD13,MAD5))+1),LLV(L,BARSLAST(CROSS
(MAD13,MAD5))+1),H=HHV(H,BARSLAST(CROSS(MAD5,MAD13))+1),HHV(H,BARSLAST(CROSS
(MAD5,MAD13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MAD5,MAD13))+1),HHV(H,BARSLAST(CROSS
(MAD5,MAD13))+1),L=LLV(L,BARSLAST(CROSS(MAD13,MAD5))+1),LLV(L,BARSLAST(CROSS
(MAD13,MAD5))+1),0),COLOR00FF00;
BT:=(LLV(VADR2,2)=LLV(VADR2,7) AND COUNT(VADR2<0,2) AND CROSS(VADR2,MA(VADR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
DRAWTEXT(BT,C*0.97,'短牛'),COLORFFFFFF;
TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
DRAWTEXT(TJ2,C*0.94,'中牛'),COLORMAGENTA;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
TJ3:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
DRAWTEXT(TJ3,L*0.93,'◆牛牛'),COLORRED;

 

私募趋势操盘主图附图此主图亲自测试过也能够用于手机版指标

私募趋势操盘主图附图此主图亲自测试过也能够用于手机版指标

私募趋势操盘主图附图此主图亲自测试过也能够用于手机版指标

私募趋势操盘主图附图此主图亲自测试过也能够用于手机版指标

  >>>请使用本站搜索功能将找到更多相关私募趋势操盘主图附图此主图亲自测试过也能够用于手机版指标下载

下载地址

点这开始下载

精品股票公式

网友评论温馨提示:任何网友发表的言论必须符合国家法律,否则予以删除!

   评论摘要(共有好评 113 条) 请登陆或注册后再发表评论!

     

      验证码:

下载注意

  • 第一股票公式网发布的股票公式主要来源于各大股票论坛,在此谢谢各位老师无私分享原创公式。
  • 引入公式如发现公式名称栏空白,可能是公式使用期限已过。请尝试调整电脑时间到1997年,看能否如正常显示。
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果您发现下载链接错误,请联系管理员报告错误。
  • 第一股票公式网欢迎各位股友帮忙宣传转发本站资源,有您的支持,我们会做得更好!

猜你喜欢

网友爱看

学了又学