第一股票公式网,股票公式,股票,公式下载,指标公式 设为首页加入收藏
你的位置:第一股票公式网同花顺公式MOS量化测试主图下载

MOS量化测试主图下载

  • 公式类型:同花顺公式
  • 推荐星级:
  • 公式安全:已通过5款杀毒软件查杀,请放心下载!
  • 更新时间:2019-09-10 08:37:33
  • 相关标签:MOS量化测试主图
  • 运行环境: WinXP/Win7/Win8/Win10/Win All
  • 公式语言:用简体中文编写

MOS量化测试主图下载详细说明

第一股票公式网(www.chnmoney.com)告诉您:当前正要下载:MOS量化测试主图下载

MOS量化测试主图源码下载:

 DIFF:=100*(EMA(CLOSE,12)-EMA(CLOSE,26)),NODRAW;

DEA:=EMA(DIFF,9),NODRAW;

MACD:=(DIFF-DEA)*2,NODRAW;

死叉:=CROSS(DEA,DIFF);

N1:=BARSLAST(死叉);

N2:=REF(BARSLAST(死叉),N1+1);

N3:=REF(BARSLAST(死叉),N2+N1+2);

CL1:=LLV(LOW,N1+1);

DIFL1:=LLV(DIFF,N1+1);

CL2:=REF(CL1,N1+1);

DIFL2:=REF(DIFL1,N1+1);

CL3:=REF(CL2,N1+1);

DIFL3:=REF(DIFL2,N1+1);

PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);

MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));

PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);

MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));//第一股票公式网www.chnMoNeY.com

MDIFB2:=INTPART(DIFF/POW(10,PDIFL2));

MDIFB3:=INTPART(DIFF/POW(10,PDIFL3));

直接底部结构:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND DIFF<0 AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,0);

隔峰底部结构:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,0);

BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底部结构,2)) OR ((MDIFB3>REF(MDIFB3,2))*REF(隔峰底部结构,2)),NODRAW;

P:=CROSS(DIFF,DEA);

DRAWTEXT(FILTER(BG AND P,MACD>0),L*0.99,'●底部结构'),colormagenta;

金叉:=CROSS(DIFF,DEA);

M1:=BARSLAST(金叉);

M2:=REF(BARSLAST(金叉),M1+1);

M3:=REF(BARSLAST(金叉),M2+M1+2);

CH1:=HHV(HIGH,M1+1);

DIFH1:=HHV(DIFF,M1+1);

CH2:=REF(CH1,M1+1);

DIFH2:=REF(DIFH1,M1+1);

CH3:=REF(CH2,M1+1);

DIFH3:=REF(DIFH2,M1+1);

PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);

MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));

PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);

MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));

MDIFT2:=INTPART(DIFF/POW(10,PDIFH2));

MDIFT3:=INTPART(DIFF/POW(10,PDIFH3));

直接顶部结构:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND DIFF>0 AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,0);

隔峰顶部结构:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,0);

TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶部结构,2)) OR ((MDIFT3<REF(MDIFT3,2))*REF(隔峰顶部结构,2)),NODRAW;

Q:=CROSS(DEA,DIFF);

DRAWTEXT(FILTER(TG AND Q,MACD<0),H*1.02,'●顶部结构'),colorgreen;

W1:=FILTER(IF(HHVBARS(HIGH,13),0,1),13);

DRAWTEXT(W1 AND STRFIND(PERIODNAME,'日线'),H*1.01,'时间'),coloryellow;

W2:=FILTER(IF(LLVBARS(LOW,13),0,1),13);

DRAWTEXT(W2 AND STRFIND(PERIODNAME,'日线'),H*1.01,'时间'),coloryellow;

A1:=C>REF(C,4);

NT:=BARSLASTCOUNT(A1);

TJ11:=NT=9;

TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);

AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;

DRAWTEXT(NT=9,H*1.007,'▲高点'),colorgreen;

K1:=REF(C,0)>REF(C,13);

K2:=REF(NT=9,13);

DRAWTEXT(K1 AND K2 AND STRFIND(PERIODNAME,'日线'),H*1.007,'■顶'),colorred;

B1:=C<REF(C,4);

NT0:=BARSLASTCOUNT(B1);

TJ21:=NT0=9 ;

TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);

AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;

DRAWTEXT(NT0=9,L*0.994,'▲低点'),colorred;

T1:=REF(C,0)<REF(C,13);

T2:=REF(NT0=9,13);

DRAWTEXT(T1 AND T2 AND STRFIND(PERIODNAME,'日线'),L*0.994,'■底'),colorgreen;

A1A:=EMA(CLOSE, 9);//www.chHnmoNeY.com

A1B:=((A1A - EMA(CLOSE, 5)) < 0);

A1C:=((A1A - EMA(CLOSE, 5)) > 0);

A1D:=BARSLAST(A1B);

A1E:=BARSLAST(A1C);

A1F:=IF((A1E > 0),(CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,0);

A20:=SUM(A1F,0);

A21:=IF((A1D > 0),(0 - 2),0);

A22:=IF((A1E > 0),SUM((CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,A1E),0);

A23:=A22 / A1E;

A25:=EMA(EMA(EMA(CLOSE, 3), 3), 3);

上升通道:((A25 - REF(A25, 1)) + A25),colorred;

反转通道:MA(上升通道, 15),colorgreen;

DRAWTEXT(CROSS(C,反转通道) AND STRFIND(PERIODNAME,"日线"),L*0.994,'↑多头'),colorlired;

DRAWTEXT(CROSS(反转通道,C) AND STRFIND(PERIODNAME,"日线"),H*1.01,'↓空头'),colorblue;
 

MOS量化测试主图

  >>>请使用本站搜索功能将找到更多相关MOS量化测试主图下载

下载地址

点这开始下载

上一公式:波段风险副图下载

下一公式:x波段下载

精品股票公式

网友评论温馨提示:任何网友发表的言论必须符合国家法律,否则予以删除!

   评论摘要(共有好评 133 条) 请登陆或注册后再发表评论!

     

      验证码:

下载注意

  • 第一股票公式网发布的股票公式主要来源于各大股票论坛,在此谢谢各位老师无私分享原创公式。
  • 引入公式如发现公式名称栏空白,可能是公式使用期限已过。请尝试调整电脑时间到1997年,看能否如正常显示。
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果您发现下载链接错误,请联系管理员报告错误。
  • 第一股票公式网欢迎各位股友帮忙宣传转发本站资源,有您的支持,我们会做得更好!

猜你喜欢

网友爱看

学了又学